re = /\[(?<TimeStamp>\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2}\.\d+)\]\s+\[(?<Level>\w+)\]\s+\[(?<Symbol>\S+)\]\s*(?<Message>.*)/m
str = '[2025-11-25 09:03:04.409] [Info] [enso.rt.ga.server.SystemRpc] ...Successful'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end