// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[(?<TimeStamp>\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2}\.\d+)\]\s+\[(?<Level>\w+)\]\s+\[(?<Symbol>\S+)\]\s*(?<Message>.*)").unwrap();
let string = "[2025-11-25 09:03:04.409] [Info] [enso.rt.ga.server.SystemRpc] ...Successful";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}