use strict;
my $str = '[2025-11-25 09:03:04.409] [Info] [enso.rt.ga.server.SystemRpc] ...Successful';
my $regex = qr/\[(?<TimeStamp>\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2}\.\d+)\]\s+\[(?<Level>\w+)\]\s+\[(?<Symbol>\S+)\]\s*(?<Message>.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}