const regex = /https?:\/\/\w+(?:\.\w+\/?)+(?!\.{3})(\s|$)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https?:\\\/\\\/\\w+(?:\\.\\w+\\\/?)+(?!\\.{3})(\\s|$)', 'gi')
const str = `sometext http://google.com sometext http://google.com/ sometext https://google.com sometext https://google.com/ sometext //google.com sometext //google.com/ sometext //g-o-o.g-l-e.com sometext http://goog… sometext https://go… sometext https://google sometext https://google.com/blah… sometext`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}