import re
regex = re.compile(r"https?:\/\/\w+(?:\.\w+\/?)+(?!\.{3})(\s|$)", flags=re.IGNORECASE)
test_str = "sometext http://google.com sometext http://google.com/ sometext https://google.com sometext https://google.com/ sometext //google.com sometext //google.com/ sometext //g-o-o.g-l-e.com sometext http://goog… sometext https://go… sometext https://google sometext https://google.com/blah… sometext"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")