$re = '/https?:\/\/\w+(?:\.\w+\/?)+(?!\.{3})(\s|$)/i';
$str = 'sometext http://google.com sometext http://google.com/ sometext https://google.com sometext https://google.com/ sometext //google.com sometext //google.com/ sometext //g-o-o.g-l-e.com sometext http://goog… sometext https://go… sometext https://google sometext https://google.com/blah… sometext';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);