re = /https?:\/\/\w+(?:\.\w+\/?)+(?!\.{3})(\s|$)/i
str = 'sometext http://google.com sometext http://google.com/ sometext https://google.com sometext https://google.com/ sometext //google.com sometext //google.com/ sometext //g-o-o.g-l-e.com sometext http://goog… sometext https://go… sometext https://google sometext https://google.com/blah… sometext'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end