const regex = /[\/^](leaflet|mapbox)[\-\._]?([\w\-\._]*)\.js\??/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\\/^](leaflet|mapbox)[\\-\\._]?([\\w\\-\\._]*)\\.js\\??', 'g')
const str = `leaflet-0.7.2.js
^leaflet-0.7.2.js <-- Does anyone actually uses "^" in a filename?
/leaflet-0.7.2.js
http://leafletjs.com/dist/leaflet.js
https://api.tiles.mapbox.com/mapbox.js/v1.6.3/mapbox.js
http://example.com/path/to/leaflet-0.7.2.js
http://example.com/path/to/mapbox-v1.6.2.js
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}