import Foundation
let pattern = #"[\/^](leaflet|mapbox)[\-\._]?([\w\-\._]*)\.js\??"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
leaflet-0.7.2.js
^leaflet-0.7.2.js <-- Does anyone actually uses "^" in a filename?
/leaflet-0.7.2.js
http://leafletjs.com/dist/leaflet.js
https://api.tiles.mapbox.com/mapbox.js/v1.6.3/mapbox.js
http://example.com/path/to/leaflet-0.7.2.js
http://example.com/path/to/mapbox-v1.6.2.js
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)