import re
regex = re.compile(r"[\/^](leaflet|mapbox)[\-\._]?([\w\-\._]*)\.js\??")
test_str = ("leaflet-0.7.2.js\n"
"^leaflet-0.7.2.js <-- Does anyone actually uses \"^\" in a filename?\n"
"/leaflet-0.7.2.js\n"
"http://leafletjs.com/dist/leaflet.js\n"
"https://api.tiles.mapbox.com/mapbox.js/v1.6.3/mapbox.js\n"
"http://example.com/path/to/leaflet-0.7.2.js\n"
"http://example.com/path/to/mapbox-v1.6.2.js\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")