re = /[\/^](leaflet|mapbox)[\-\._]?([\w\-\._]*)\.js\??/
str = 'leaflet-0.7.2.js
^leaflet-0.7.2.js <-- Does anyone actually uses "^" in a filename?
/leaflet-0.7.2.js
http://leafletjs.com/dist/leaflet.js
https://api.tiles.mapbox.com/mapbox.js/v1.6.3/mapbox.js
http://example.com/path/to/leaflet-0.7.2.js
http://example.com/path/to/mapbox-v1.6.2.js
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end