import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\W\\S]\\s[\\w\\W]{2}.+),\\s(.+)\\1([!?.])";
final String string = "Dios mÃo, ¡está aquÃ, está aquÃ, está aquÃ!\n\n"
+ "¿Qué paso, qué paso?\n\n"
+ "Me rehúso, me rehúso.\n\n"
+ "No, no, no, no.";
final String subst = "$1$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}