const regex = /(?=(\d{1,3}\.){3}\d{1,3})((?:(2[0-5]{2}|[1]?\d{1,2}))\.){3}(?:(2[0-5]{2}|[1]?\d{1,2}))(?![\.\d])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=(\\d{1,3}\\.){3}\\d{1,3})((?:(2[0-5]{2}|[1]?\\d{1,2}))\\.){3}(?:(2[0-5]{2}|[1]?\\d{1,2}))(?![\\.\\d])', 'g')
const str = `1.2.3.4 255.100.196.123 256.100.203.1 1.2.3.4 1.2.3.4.5 123.456.78.90 123.45.67.89
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}