use strict;
my $str = '1.2.3.4 255.100.196.123 256.100.203.1 1.2.3.4 1.2.3.4.5 123.456.78.90 123.45.67.89
';
my $regex = qr/(?=(\d{1,3}\.){3}\d{1,3})((?:(2[0-5]{2}|[1]?\d{1,2}))\.){3}(?:(2[0-5]{2}|[1]?\d{1,2}))(?![\.\d])/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}