import re
regex = re.compile(r"(?=(\d{1,3}\.){3}\d{1,3})((?:(2[0-5]{2}|[1]?\d{1,2}))\.){3}(?:(2[0-5]{2}|[1]?\d{1,2}))(?![\.\d])")
test_str = ("1.2.3.4 255.100.196.123 256.100.203.1 1.2.3.4 1.2.3.4.5 123.456.78.90 123.45.67.89\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")