import Foundation
let pattern = #"(?=(\d{1,3}\.){3}\d{1,3})((?:(2[0-5]{2}|[1]?\d{1,2}))\.){3}(?:(2[0-5]{2}|[1]?\d{1,2}))(?![\.\d])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1.2.3.4 255.100.196.123 256.100.203.1 1.2.3.4 1.2.3.4.5 123.456.78.90 123.45.67.89
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)