#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((<div class="dotted-highlight">)([^<\n]*)\s?).*?\2.*?<ul>"
Local $sString = "<div class="dotted-highlight">The cover letter should include: " & @CRLF & _
"<div class="dotted-highlight"><ul>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")