re = /((<div class="dotted-highlight">)([^<\n]*)\s?).*?\2.*?<ul>/
str = '<div class="dotted-highlight">The cover letter should include:
<div class="dotted-highlight"><ul>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end