import re
regex = re.compile(r"((<div class=\"dotted-highlight\">)([^<\n]*)\s?).*?\2.*?<ul>")
test_str = ("<div class=\"dotted-highlight\">The cover letter should include: \n"
"<div class=\"dotted-highlight\"><ul>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")