using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((<div class=""dotted-highlight"">)([^<\n]*)\s?).*?\2.*?<ul>";
string input = @"<div class=""dotted-highlight"">The cover letter should include:
<div class=""dotted-highlight""><ul>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}