$re = '/((<div class="dotted-highlight">)([^<\n]*)\s?).*?\2.*?<ul>/';
$str = '<div class="dotted-highlight">The cover letter should include:
<div class="dotted-highlight"><ul>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);