const regex = new RegExp('(?=\\s*?)(console)\\.(log)\\((.*?)\\)(\\;|\\s*?)', 'gmi')
const str = `console.log(dasdsadsadasdaddasd);
console.log(dsadsadsadasddsadsadsassssssssssssssssssssssssssssssssssssssssssssssssssssssssssssdsadsadsadsadxczxczxcxzczxcxzcxzc);`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);