re = /(?=\s*?)(console)\.(log)\((.*?)\)(\;|\s*?)/mi
str = 'console.log(dasdsadsadasdaddasd);
console.log(dsadsadsadasddsadsadsassssssssssssssssssssssssssssssssssssssssssssssssssssssssssssdsadsadsadsadxczxczxcxzczxcxzcxzc);'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result