$re = '/(?=\s*?)(console)\.(log)\((.*?)\)(\;|\s*?)/mi';
$str = 'console.log(dasdsadsadasdaddasd);
console.log(dsadsadsadasddsadsadsassssssssssssssssssssssssssssssssssssssssssssssssssssssssssssdsadsadsadsadxczxczxcxzczxcxzcxzc);';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;