#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\S+), (\S+)(.*(?!,)).*?\n"
Local $sString = "lastname1, firstname1 middlename1" & @CRLF & _
"lastname1, firstname1 middlename1 lastname2, firstname2 middlename2" & @CRLF & _
"lastname1, firstname1" & @CRLF & _
"lastname1, firstname1 lastname2, firstname2" & @CRLF & _
"lastname1, firstname1 lastname2, firstname2" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")