const regex = /(\S+), (\S+)(.*(?!,)).*?\n/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\S+), (\\S+)(.*(?!,)).*?\\n', 'g')
const str = `lastname1, firstname1 middlename1
lastname1, firstname1 middlename1 lastname2, firstname2 middlename2
lastname1, firstname1
lastname1, firstname1 lastname2, firstname2
lastname1, firstname1 lastname2, firstname2
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}