import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\S+), (\\S+)(.*(?!,)).*?\\n";
final String string = "lastname1, firstname1 middlename1\n"
+ "lastname1, firstname1 middlename1 lastname2, firstname2 middlename2\n"
+ "lastname1, firstname1\n"
+ "lastname1, firstname1 lastname2, firstname2\n"
+ "lastname1, firstname1 lastname2, firstname2\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}