re = /(\S+), (\S+)(.*(?!,)).*?\n/
str = 'lastname1, firstname1 middlename1
lastname1, firstname1 middlename1 lastname2, firstname2 middlename2
lastname1, firstname1
lastname1, firstname1 lastname2, firstname2
lastname1, firstname1 lastname2, firstname2
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end