using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\S+), (\S+)(.*(?!,)).*?\n";
string input = @"lastname1, firstname1 middlename1
lastname1, firstname1 middlename1 lastname2, firstname2 middlename2
lastname1, firstname1
lastname1, firstname1 lastname2, firstname2
lastname1, firstname1 lastname2, firstname2
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}