#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<Device(?:(?!<\/Device).)*<Block[^>]+Name="ZG123CZ123".*?<\/Device>"
Local $sString = "<Device DevID="14212111" Model="" GroupID="">" & @CRLF & _
" <Block Name="ZG123CZ123" LastFileDld="" LastFullDld="">" & @CRLF & _
" <Group ZD="1">" & @CRLF & _
" <DSize ParamName="KEY" Value="RAM"/>" & @CRLF & _
" <DSize ParamName="REM" Value="***"/>" & @CRLF & _
" <DSize ParamName="*UNZIP" Value="I:ZG123CZ123.ZIP"/>" & @CRLF & _
" </Group>" & @CRLF & _
" <Group ZD="15">" & @CRLF & _
" <DSize ParamName="REM" Value="="***""/>" & @CRLF & _
" <DSize ParamName="#DEBUGPORT" Value=""/>" & @CRLF & _
" </Group>" & @CRLF & _
" </Block>" & @CRLF & _
" <DevFiles />" & @CRLF & _
"</Device>" & @CRLF & _
"<Device DevID="14212111" Model="" GroupID="">" & @CRLF & _
" <Block Name="DG" LastFileDld="" LastFullDld="">" & @CRLF & _
" <Group ZD="3">" & @CRLF & _
" <DSize ParamName="*UNZIP" Value="DG.ZIP"/>" & @CRLF & _
" <DSize ParamName="*GO" Value="F:DG.OUT"/>" & @CRLF & _
" </Group>" & @CRLF & _
" <Group ZD="15">" & @CRLF & _
" <DSize ParamName="#LOGPORT" Value="NONE"/>" & @CRLF & _
" <DSize ParamName="CDH6" Value=""/>" & @CRLF & _
" </Group>" & @CRLF & _
" </Block>" & @CRLF & _
" <DevFiles />" & @CRLF & _
"</Device>" & @CRLF & _
"<Device DevID="14212111" Model="" GroupID="">" & @CRLF & _
" <Block Name="ZG123CZ123" LastFileDld="" LastFullDld="">" & @CRLF & _
" <Group ZD="1">" & @CRLF & _
" <DSize ParamName="KEY" Value="RAM"/>" & @CRLF & _
" <DSize ParamName="REM" Value="***"/>" & @CRLF & _
" <DSize ParamName="*UNZIP" Value="I:ZG123CZ123.ZIP"/>" & @CRLF & _
" </Group>" & @CRLF & _
" <Group ZD="15">" & @CRLF & _
" <DSize ParamName="REM" Value="="***""/>" & @CRLF & _
" <DSize ParamName="#DEBUGPORT" Value=""/>" & @CRLF & _
" </Group>" & @CRLF & _
" </Block>" & @CRLF & _
" <DevFiles />" & @CRLF & _
"</Device>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")