using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)<Device(?:(?!<\/Device).)*<Block[^>]+Name=""ZG123CZ123"".*?<\/Device>";
string input = @"<Device DevID=""14212111"" Model="" GroupID="">
<Block Name=""ZG123CZ123"" LastFileDld="" LastFullDld="">
<Group ZD=""1"">
<DSize ParamName=""KEY"" Value=""RAM""/>
<DSize ParamName=""REM"" Value=""***""/>
<DSize ParamName=""*UNZIP"" Value=""I:ZG123CZ123.ZIP""/>
</Group>
<Group ZD=""15"">
<DSize ParamName=""REM"" Value=""=""***""/>
<DSize ParamName=""#DEBUGPORT"" Value=""/>
</Group>
</Block>
<DevFiles />
</Device>
<Device DevID=""14212111"" Model="" GroupID="">
<Block Name=""DG"" LastFileDld="" LastFullDld="">
<Group ZD=""3"">
<DSize ParamName=""*UNZIP"" Value=""DG.ZIP""/>
<DSize ParamName=""*GO"" Value=""F:DG.OUT""/>
</Group>
<Group ZD=""15"">
<DSize ParamName=""#LOGPORT"" Value=""NONE""/>
<DSize ParamName=""CDH6"" Value=""/>
</Group>
</Block>
<DevFiles />
</Device>
<Device DevID=""14212111"" Model="" GroupID="">
<Block Name=""ZG123CZ123"" LastFileDld="" LastFullDld="">
<Group ZD=""1"">
<DSize ParamName=""KEY"" Value=""RAM""/>
<DSize ParamName=""REM"" Value=""***""/>
<DSize ParamName=""*UNZIP"" Value=""I:ZG123CZ123.ZIP""/>
</Group>
<Group ZD=""15"">
<DSize ParamName=""REM"" Value=""=""***""/>
<DSize ParamName=""#DEBUGPORT"" Value=""/>
</Group>
</Block>
<DevFiles />
</Device>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}