import Foundation
let pattern = #"(?s)<Device(?:(?!<\/Device).)*<Block[^>]+Name="ZG123CZ123".*?<\/Device>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
<Device DevID="14212111" Model="" GroupID="">
<Block Name="ZG123CZ123" LastFileDld="" LastFullDld="">
<Group ZD="1">
<DSize ParamName="KEY" Value="RAM"/>
<DSize ParamName="REM" Value="***"/>
<DSize ParamName="*UNZIP" Value="I:ZG123CZ123.ZIP"/>
</Group>
<Group ZD="15">
<DSize ParamName="REM" Value="="***""/>
<DSize ParamName="#DEBUGPORT" Value=""/>
</Group>
</Block>
<DevFiles />
</Device>
<Device DevID="14212111" Model="" GroupID="">
<Block Name="DG" LastFileDld="" LastFullDld="">
<Group ZD="3">
<DSize ParamName="*UNZIP" Value="DG.ZIP"/>
<DSize ParamName="*GO" Value="F:DG.OUT"/>
</Group>
<Group ZD="15">
<DSize ParamName="#LOGPORT" Value="NONE"/>
<DSize ParamName="CDH6" Value=""/>
</Group>
</Block>
<DevFiles />
</Device>
<Device DevID="14212111" Model="" GroupID="">
<Block Name="ZG123CZ123" LastFileDld="" LastFullDld="">
<Group ZD="1">
<DSize ParamName="KEY" Value="RAM"/>
<DSize ParamName="REM" Value="***"/>
<DSize ParamName="*UNZIP" Value="I:ZG123CZ123.ZIP"/>
</Group>
<Group ZD="15">
<DSize ParamName="REM" Value="="***""/>
<DSize ParamName="#DEBUGPORT" Value=""/>
</Group>
</Block>
<DevFiles />
</Device>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)