import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)<Device(?:(?!<\\/Device).)*<Block[^>]+Name=\"ZG123CZ123\".*?<\\/Device>";
final String string = "<Device DevID=\"14212111\" Model=\"\" GroupID=\"\">\n"
+ " <Block Name=\"ZG123CZ123\" LastFileDld=\"\" LastFullDld=\"\">\n"
+ " <Group ZD=\"1\">\n"
+ " <DSize ParamName=\"KEY\" Value=\"RAM\"/>\n"
+ " <DSize ParamName=\"REM\" Value=\"***\"/>\n"
+ " <DSize ParamName=\"*UNZIP\" Value=\"I:ZG123CZ123.ZIP\"/>\n"
+ " </Group>\n"
+ " <Group ZD=\"15\">\n"
+ " <DSize ParamName=\"REM\" Value=\"=\"***\"\"/>\n"
+ " <DSize ParamName=\"#DEBUGPORT\" Value=\"\"/>\n"
+ " </Group>\n"
+ " </Block>\n"
+ " <DevFiles />\n"
+ "</Device>\n"
+ "<Device DevID=\"14212111\" Model=\"\" GroupID=\"\">\n"
+ " <Block Name=\"DG\" LastFileDld=\"\" LastFullDld=\"\">\n"
+ " <Group ZD=\"3\">\n"
+ " <DSize ParamName=\"*UNZIP\" Value=\"DG.ZIP\"/>\n"
+ " <DSize ParamName=\"*GO\" Value=\"F:DG.OUT\"/>\n"
+ " </Group>\n"
+ " <Group ZD=\"15\">\n"
+ " <DSize ParamName=\"#LOGPORT\" Value=\"NONE\"/>\n"
+ " <DSize ParamName=\"CDH6\" Value=\"\"/>\n"
+ " </Group>\n"
+ " </Block>\n"
+ " <DevFiles />\n"
+ "</Device>\n"
+ "<Device DevID=\"14212111\" Model=\"\" GroupID=\"\">\n"
+ " <Block Name=\"ZG123CZ123\" LastFileDld=\"\" LastFullDld=\"\">\n"
+ " <Group ZD=\"1\">\n"
+ " <DSize ParamName=\"KEY\" Value=\"RAM\"/>\n"
+ " <DSize ParamName=\"REM\" Value=\"***\"/>\n"
+ " <DSize ParamName=\"*UNZIP\" Value=\"I:ZG123CZ123.ZIP\"/>\n"
+ " </Group>\n"
+ " <Group ZD=\"15\">\n"
+ " <DSize ParamName=\"REM\" Value=\"=\"***\"\"/>\n"
+ " <DSize ParamName=\"#DEBUGPORT\" Value=\"\"/>\n"
+ " </Group>\n"
+ " </Block>\n"
+ " <DevFiles />\n"
+ "</Device>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}