package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<motif>[^-]+)\s-\s(?<commune>.+)\s\s(?<voie>.*)\s-\s(?<vehicule>.+)`)
var str = `DEP. CHAUDIERE - COMMUNE 12 BIS UNE VOIE - VEHICULE 1`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}