const regex = new RegExp('(?<motif>[^-]+)\\s-\\s(?<commune>.+)\\s\\s(?<voie>.*)\\s-\\s(?<vehicule>.+)', '')
const str = `DEP. CHAUDIERE - COMMUNE 12 BIS UNE VOIE - VEHICULE 1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}