import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<motif>[^-]+)\\s-\\s(?<commune>.+)\\s\\s(?<voie>.*)\\s-\\s(?<vehicule>.+)";
final String string = "DEP. CHAUDIERE - COMMUNE 12 BIS UNE VOIE - VEHICULE 1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}