$re = '~(?<motif>[^-]+)\s-\s(?<commune>.+)\s\s(?<voie>.*)\s-\s(?<vehicule>.+)~';
$str = 'DEP. CHAUDIERE - COMMUNE 12 BIS UNE VOIE - VEHICULE 1';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);