re = /(?<motif>[^-]+)\s-\s(?<commune>.+)\s\s(?<voie>.*)\s-\s(?<vehicule>.+)/
str = 'DEP. CHAUDIERE - COMMUNE 12 BIS UNE VOIE - VEHICULE 1'
# Print the match result
str.match(re) do |match|
puts match.to_s
end