#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\[[^][]+](?:\s*\[[^][]+])*)?\s*(.*)"
Local $sString = "some_txt" & @CRLF & _
" # → some_txt" & @CRLF & _
"[info1]some_txt" & @CRLF & _
" # → some_txt" & @CRLF & _
"[info1][info2] some_text" & @CRLF & _
" # → some_txt" & @CRLF & _
"[info1][info2] some_text_with_[___]_abc" & @CRLF & _
" # → some_text_with_[___]_abc" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")