// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\[[^][]+](?:\s*\[[^][]+])*)?\s*(.*)").unwrap();
let string = "some_txt
# → some_txt
[info1]some_txt
# → some_txt
[info1][info2] some_text
# → some_txt
[info1][info2] some_text_with_[___]_abc
# → some_text_with_[___]_abc
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}