import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\[[^][]+](?:\\s*\\[[^][]+])*)?\\s*(.*)";
final String string = "some_txt\n"
+ " # → some_txt\n"
+ "[info1]some_txt\n"
+ " # → some_txt\n"
+ "[info1][info2] some_text\n"
+ " # → some_txt\n"
+ "[info1][info2] some_text_with_[___]_abc\n"
+ " # → some_text_with_[___]_abc\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}