$re = '/^(?:\[[^][]+](?:\s*\[[^][]+])*)?\s*(.*)/m';
$str = 'some_txt
# → some_txt
[info1]some_txt
# → some_txt
[info1][info2] some_text
# → some_txt
[info1][info2] some_text_with_[___]_abc
# → some_text_with_[___]_abc
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);