re = /^(?:\[[^][]+](?:\s*\[[^][]+])*)?\s*(.*)/m
str = 'some_txt
# → some_txt
[info1]some_txt
# → some_txt
[info1][info2] some_text
# → some_txt
[info1][info2] some_text_with_[___]_abc
# → some_text_with_[___]_abc
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end