using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!^)|\bstyle="")([^:]*):\s*([^;]*)[;""](?=[^>]*>)";
string substitution = @"$1=""$2"" ";
string input = @"<table border=""0"" cellpadding=""0"" cellspacing=""0"" width=""100%"" style=""font-family: Helvetica;line-height: 100%;margin-top: 20px; text-align: left;vertical-align: bottom;color: #202020"">";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}