$re = '/(?:\G(?!^)|\bstyle=")([^:]*):\s*([^;]*)[;"](?=[^>]*>)/';
$str = '<table border="0" cellpadding="0" cellspacing="0" width="100%" style="font-family: Helvetica;line-height: 100%;margin-top: 20px; text-align: left;vertical-align: bottom;color: #202020">';
$subst = "$1=\"$2\" ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;