import Foundation
let pattern = #"(?:\G(?!^)|\bstyle=")([^:]*):\s*([^;]*)[;"](?=[^>]*>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"<table border="0" cellpadding="0" cellspacing="0" width="100%" style="font-family: Helvetica;line-height: 100%;margin-top: 20px; text-align: left;vertical-align: bottom;color: #202020">"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1="$2" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)