const regex = /(?:\G(?!^)|\bstyle=")([^:]*):\s*([^;]*)[;"](?=[^>]*>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!^)|\\bstyle=")([^:]*):\\s*([^;]*)[;"](?=[^>]*>)', 'g')
const str = `<table border="0" cellpadding="0" cellspacing="0" width="100%" style="font-family: Helvetica;line-height: 100%;margin-top: 20px; text-align: left;vertical-align: bottom;color: #202020">`;
const subst = `$1="$2" `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);