use strict;
my $str = '<table border="0" cellpadding="0" cellspacing="0" width="100%" style="font-family: Helvetica;line-height: 100%;margin-top: 20px; text-align: left;vertical-align: bottom;color: #202020">';
my $regex = qr/(?:\G(?!^)|\bstyle=")([^:]*):\s*([^;]*)[;"](?=[^>]*>)/p;
my $subst = '$1="$2" ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";