using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-zA-Z]+|[!@#$%^&*()_=;.?])[0-9]+";
string input = @"jkl3242oij92384nji332332!23#900&6382^832983@7729.979797_70979797";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}