$re = '/([a-zA-Z]+|[!@#$%^&*()_=;.?])[0-9]+/';
$str = 'jkl3242oij92384nji332332!23#900&6382^832983@7729.979797_70979797';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);